What equipment is needed for Remote Deposit?

The following are the minimum currently supported environments.

For Home Scanning:

  • Windows XP or Vista with Internet Explorer 7+
  • Windows XP or Vista with Firefox 2+
  • Mac OS X 10.6 with Safari 3+ (must be run in 32-bit mode)
  • Mac OS X 10.6 with Firefox 2+
  • TWAIN-compliant document scanner

Note:To find out if your scanner is compliant, refer to the documentation that was supplied with the scanner. For help with your scanner, log in to your SFCU Online Banking account and click on the Remote Deposits link. Then click on “Help with Scanners and Drivers” near the bottom of the screen.)

Note: The recommended version of the browsers listed above are Internet Explorer 8, Firefox 3, and Safari 3.1.

For Mobile Devices:

  • For iPhone, the free SFCU app, available through the App Store.
  • For Android phones, the free SFCU app, available through the Google Play Store.

Help Center